ATS-PTプラグイン ver 3.3.4 な(ry EditionWindows10でBVE5

二〇一五年文月十七日

Ruby 開発環境準備 (Windows7) 3

前回:http://iliketrain02.blog.jp/archives/26858530.html 

 Window環境でRubyが動いたやったねと思っていたら、他の環境と共同で作っている関係でエラーが発生しました。

 

①サーバーが起動しなくなった
> bundle install
を実行したらrails serverが起動しなくなった(cannot such file -- mysql2/2.2/mysql2)

> gem uninstall mysql2
でmysql2を一旦削除(すべてのバージョン)

> gem install mysql2 --platform=ruby -- '--with-mysql-include="c:\mysql-connector-c-6.1.6-win32\include" --with-mysql-lib="c:\mysql-connector-c-6.1.6-win32\lib"' 
を実行した後(ファイル名などは前回を参照)、

> rails server
で復旧完了
bundle installをやるたびにこの作業をしないといけないようだ。

 ②CoffeeScriptを使用するとエラー
TypeError: オブジェクトでサポートされていないプロパティまたはメソッドです

 WindowsのJavaScriptの処理体系 (WHS)に対応していないAPIが呼び出されている。WHSからNode.jsに変える

http://nodejs.org/よりインストーラをダウンロード
インストール後、コマンドプロンプトを再起動してサーバーを起動させる
 


このエントリーをはてなブックマークに追加 Clip to Evernote
iliketrain at 23:44│Comments(0)TrackBack(0)Ruby 

トラックバックURL

コメントする

名前
 
  絵文字
 
 
ATS-PTプラグイン ver 3.3.4 な(ry EditionWindows10でBVE5